ビットマップハックとは？

何ができるの？

ビットマップはBMPファイルだけではなく、実行ファイルやDLLファイルやその他さまざまなファイルの中にリソースという形で存在しています。「ビットマップハック」は、そうした通常使うことのできないリソースの中から、ビットマップを取り出しBMPファイルで出力するツールです。

名前の由来

「ビットマップハック」とは「ディスクに埋もれたビットマップを発掘する」という意味から付けられた名前です。ビットマップに関してハッカー的なことをするという意味ではありません。(^^);。


特徴

各種ファイルからビットマップを抽出

抽出元のファイルは制限がありません。EXE、DLL、OCX、CPL など様々なファイルの中から取り出すことができます。

アイコン、カーソルも抽出

アイコン、カーソルはビットマップとは多少格納形式が異なりますが、独自のアルゴリズムで正しくビットマップとして抽出します｡

サブディレクトリまで一括抽出

ビットマップを取り出す際、サブディレクトリまで自動で検索抽出する機能がありますので、たとえばCD-ROM中にある全ビットマップを取り出すなんて事も簡単にできます。


使用上の注意

  • 抽出されたビットマップファイルが大量にある場合、ハードディスクの容量不足によりエラーが発生することがあります。それがシステムのドライブであったりするとWindowsの動作が不安定になることがあります。あらかじめ十分な容量があることを確認してください。いきなりC:\からフォルダ抽出するとかは避けたほうがいいでしょう。

  • 抽出したビットマップの著作権は各ビットマップイメージの作成者にあります。個人で楽しむ以外の用途においては各ビットマップの著作権保持者の指示に従ってください。


インストール方法

専用のディレクトリを作成して、そこに同梱されている全ファイルを解凍します。あとは普通に実行してください。レジストリは使用していません。


アンインストール方法

プログラムの入っているフォルダを単に削除してください。レジストリは使用していませんのでこれで全てクリーンになります。


ビットマップを抽出する

フォルダから抽出する

フォルダ選択ダイアログが出るので抽出をするフォルダを選択してください｡選択したフォルダ以下の全てのフォルダ及びファイルを対象として抽出を行います｡

ファイルから抽出する

ファイル選択ダイアログが出るので抽出をするファイルを選択してください｡選択したファイルのみを対象として抽出を行います｡


保存先を変更する

抽出したビットマップは保存先:の欄にあるディレクトリに保存されますが、これを変更したいときはディレクトリ表示欄の一番右の小さいボタンを押して変更してください。


抽出対象オプション

アイコンファイル

チェックされていると拡張子がICOのものを抽出対象外とします。

カーソルファイル

チェックされていると拡張子がCURのものを抽出対象外とします。

アイコンリソース

チェックされているとファイルに含まれている形式からアイコンと判断されたものを抽出対象外とします。

カーソルリソース

チェックされているとファイルに含まれている形式からアイコンと判断されたものを抽出対象外とします。

注意

  • 拡張子がBmpのファイルは抽出対象としません。同じ物ができるだけですから。

  • アイコンリソース、カーソルリソースの判断はまれに間違うことがあります。見過ごしてやってください。


ファイル関連オプション

抽出前に保存先の全てのビットマップを削除する

そのままです。拡張子がBMPのものだけを対象とします。

抽出後にフォルダを開く

これも説明不要ですね。保存先に指定したフォルダが開きます。抽出したビットマップが多いとちょっと時間がかかることがあります。


Ｑ＆Ａ

ご意見、ご感想、ご質問なんでも結構｡待ってます。たくさん来たらここに追加していきます。


権利／義務／サポート等について

  • 「ビットマップハック」はフリーウェアです。著作権は mye が有します。

  • 本プログラムを使用することによって発生した損害等に対して、著作者は責任を負いません。これに同意できない方は使用しないで下さい。

  • 著作者はバグ対応等をできる限り行いますが、ご期待に添えない場合もあります。あらかじめご了承下さい。

  • 再配布、転載、雑誌等での紹介等については、必ず事前にメール等で連絡して下さい。雑誌での紹介や、付録としてのバンドルに関しては、見本誌の送付を希望します。

  • ご意見・ご要望等はメールで受け付けます。気軽にお寄せ下さい。


変更履歴

2000年2月13日 Ver1.0

初代バージョン (^o^)/


著作者情報

電子メール宛先

myesoft@nifty.com

ホームページ

「ＭＹＥソフトのホームページ」
http://www.vector.co.jp/authors/VA006216/

動作確認環境

自作DOSV ３号機 + Windows98

パソコン歴

1978年 | Sharp MZ-80 で初めてパソコンを使う。
1980年 | 日立BASICマスターレベル２を主に使って雑誌等に投稿・初掲載。
1982年 | Sharp X1を購入。
1984年 | Sharp X1Turboを購入。雑誌投稿のかたわら市販ソフト２本作成。
1986年 | パソコンに飽きてTurboを売却。以後、仕事以外ではパソコンを使わない日々が続く。家でパソコン使う人の気が知れないなんて思っていた。
1994年 | 何となく衝動買いで無印AT互換機(P5-90)を購入。NIFTY-Serveに加入。
1995年 | フリーソフト・シェアウェア作成を始める。
1996年 | ホームページ開設。２代目のAT互換機を自作。自宅にＬＡＮを構築。
1997年 | WindowsNT4.0Jを導入。
1998年 | ダイアルアップルータを導入。Windows98導入。自作DOSV 3号機を製作。
2000年 | CATVでインターネット常時接続環境構築

公開ソフト

  • RsFree (アイコン型リソースモニター)

  • ボタン一発！環境変更

  • アイコンハック (アイコンの抽出・管理ソフト)

  • ウィンドウズの鍵

  • ウィンドウズ９５の鍵

  • アイコンハック９５ (アイコンの抽出・管理ソフト)

  • ビットマップハック (ビットマップの抽出ソフト)